re = /^([^;]+);(?:\s*([^=]+)=((?<q>\"?)[^"]*\k<q>);?)*$/m
str = 'attachment; filename="fname.ext"; param1="A"; param2="A"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end