$re = '/^([^;]+);(?:\s*([^=]+)=((?<q>\"?)[^"]*\k<q>);?)*$/m';
$str = 'attachment; filename="fname.ext"; param1="A"; param2="A"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);