import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=( ?\\d){5} *$)\\d* ?\\d*";
final String string = "73648\n"
+ "3 0324\n"
+ " 98734\n"
+ "98234 \n\n"
+ "324234\n"
+ "324 343\n"
+ "33 345\n\n"
+ "f7364ffff8f ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}