using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(((0|[1-9]\d*)?\.\d*|0|[1-9]\d*)?ı((0|[1-9]\d*)?\.\d*|0|[1-9]\d*)?)|((0|[1-9]\d*)?\.\d*|0|[1-9]\d*)";
string input = @"x.y
1.
.1
.
1.1ı1.1
1.ı1.1
.1ı1.1
1.1ı1
1.1ı1
.ı
.ı.
1.1ı.1
1.1ı1.
.1ı.1
.1ı1.
.ı1.1
.ı1.
.ı.1
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}