const regex = /(((0|[1-9]\d*)?\.\d*|0|[1-9]\d*)?ı((0|[1-9]\d*)?\.\d*|0|[1-9]\d*)?)|((0|[1-9]\d*)?\.\d*|0|[1-9]\d*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(((0|[1-9]\\d*)?\\.\\d*|0|[1-9]\\d*)?ı((0|[1-9]\\d*)?\\.\\d*|0|[1-9]\\d*)?)|((0|[1-9]\\d*)?\\.\\d*|0|[1-9]\\d*)', 'gm')
const str = `x.y
1.
.1
.
1.1ı1.1
1.ı1.1
.1ı1.1
1.1ı1
1.1ı1
.ı
.ı.
1.1ı.1
1.1ı1.
.1ı.1
.1ı1.
.ı1.1
.ı1.
.ı.1
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}