import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(((0|[1-9]\\d*)?\\.\\d*|0|[1-9]\\d*)?ı((0|[1-9]\\d*)?\\.\\d*|0|[1-9]\\d*)?)|((0|[1-9]\\d*)?\\.\\d*|0|[1-9]\\d*)";
final String string = "x.y\n"
+ "1.\n"
+ ".1\n"
+ ".\n"
+ "1.1ı1.1\n"
+ "1.ı1.1\n"
+ ".1ı1.1\n"
+ "1.1ı1\n"
+ "1.1ı1\n"
+ ".ı\n"
+ ".ı.\n"
+ "1.1ı.1\n"
+ "1.1ı1.\n"
+ ".1ı.1\n"
+ ".1ı1.\n"
+ ".ı1.1\n"
+ ".ı1.\n"
+ ".ı.1\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}