using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[a-z\d]";
string input = @"լոռեմ իպսում դոլոռ սիթ ամեթ, նե եամ դոլոռեմ ածծոմմոդառե, վիմ ինանի պեռֆեծթո ռաթիոնիբուս ծու, պոսսե վիռիս ոպոռթեռե եխ վել. նե սուաս նոսթռուդ պեռ, ութռոքուե սալութանդի դեֆինիթիոնես ծում եթ, բլանդիթ ռեպռեհենդունթ նեծ ադ. նոսթեռ պռոբաթուս ութ վել, եա ալթեռա աեթեռնո աթոմոռում եում, նոմինավի թածիմաթես դելիծաթա ծու ուսու. սթեթ թոլլիթ ""Hi There"" 12345679";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}