// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?iu)[a-z\d]").unwrap();
let string = "լոռեմ իպսում դոլոռ սիթ ամեթ, նե եամ դոլոռեմ ածծոմմոդառե, վիմ ինանի պեռֆեծթո ռաթիոնիբուս ծու, պոսսե վիռիս ոպոռթեռե եխ վել. նե սուաս նոսթռուդ պեռ, ութռոքուե սալութանդի դեֆինիթիոնես ծում եթ, բլանդիթ ռեպռեհենդունթ նեծ ադ. նոսթեռ պռոբաթուս ութ վել, եա ալթեռա աեթեռնո աթոմոռում եում, նոմինավի թածիմաթես դելիծաթա ծու ուսու. սթեթ թոլլիթ \"Hi There\" 12345679";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}