package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:N|S|E|W|NW|NE|SW|SE)$`)
var str = `N
S
E
W
NW
NE
SW
SE
SED
NEW`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}