import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:N|S|E|W|NW|NE|SW|SE)$";
final String string = "N\n"
+ "S\n"
+ "E\n"
+ "W\n"
+ "NW\n"
+ "NE\n"
+ "SW\n"
+ "SE\n"
+ "SED\n"
+ "NEW";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}