# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(-)?(\d+)(?:[\s\.]0+)?\s*(?:USD)?$"
test_str = ("123.00 USD\n"
"1234 USD\n"
"357.0 USD\n"
"456 00 USD\n"
"651USD\n"
"753.684 USD\n"
"123 456 USD\n"
"-123 USD\n"
"789.00 XXX\n"
"123.00 wrongcurrency\n"
"test string\n"
"$159\n"
"123")
subst = "\\0 => \\1$\\2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.