import Foundation
let pattern = #"^(-)?(\d+)(?:[\s\.]0+)?\s*(?:USD)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
123.00 USD
1234 USD
357.0 USD
456 00 USD
651USD
753.684 USD
123 456 USD
-123 USD
789.00 XXX
123.00 wrongcurrency
test string
$159
123
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\0 => \1$\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)