package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([^#].*)?^\s*dev1`)
var str = `#| Environment | Port-prefix | Subnet | Target-host |
#dev1 300 8 ibdock2
# dev1 300 8 ibdock2
#dev1 300 8 ibdock2
# dev1 300 8 ibdock2
dev1 300 8 ibdock2
dev1 300 8 ibdock2
dev 301 1 ibdock2
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}