import re
regex = re.compile(r"^([^#].*)?^\s*dev1", flags=re.MULTILINE)
test_str = ("#| Environment | Port-prefix | Subnet | Target-host |\n"
"#dev1 300 8 ibdock2\n"
"# dev1 300 8 ibdock2\n"
" #dev1 300 8 ibdock2\n"
" # dev1 300 8 ibdock2\n"
"dev1 300 8 ibdock2\n"
" dev1 300 8 ibdock2\n"
"dev 301 1 ibdock2\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)