package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\[(.+)\]`)
var str = `[JSON?data=[COURSES]&filter=[{"field":"id","operator":">=","value":1}]] текст
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}