$re = '/^\[(.+)\]/m';
$str = '[JSON?data=[COURSES]&filter=[{"field":"id","operator":">=","value":1}]] текст
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);