re = /^\[(.+)\]/m
str = '[JSON?data=[COURSES]&filter=[{"field":"id","operator":">=","value":1}]] текст
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end