package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[((?:[^\[\]]|\[(?1)\])*)\]`)
var str = `[JSON?data=[COURSES]&filter=[{"field":"id","operator":">=","value":1}]] текст [COURSES] [JSON?data=[COURSES]&filter=[{"field":"id","operator":">=","value":1}]] текст [COURSES] [JSON?data=[COURSES]&filter=[{"field":"id","operator":">=","value":1}]] текст [COURSES]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}