re = /\[((?:[^\[\]]|\[(?1)\])*)\]/
str = '[JSON?data=[COURSES]&filter=[{"field":"id","operator":">=","value":1}]] текст [COURSES] [JSON?data=[COURSES]&filter=[{"field":"id","operator":">=","value":1}]] текст [COURSES] [JSON?data=[COURSES]&filter=[{"field":"id","operator":">=","value":1}]] текст [COURSES]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end