$re = '/\[((?:[^\[\]]|\[(?1)\])*)\]/';
$str = '[JSON?data=[COURSES]&filter=[{"field":"id","operator":">=","value":1}]] текст [COURSES] [JSON?data=[COURSES]&filter=[{"field":"id","operator":">=","value":1}]] текст [COURSES] [JSON?data=[COURSES]&filter=[{"field":"id","operator":">=","value":1}]] текст [COURSES]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);