#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)#[NCRLTBUIOSFAGKP]\{(\d+):(#[NCRLTBUIOSFAGKP]\{\d+(?:;F)?\}|S|C|R)(:\d+)?\}"
Local $sString = "Ejemplos Válidos:" & @CRLF & _
"" & @CRLF & _
"Ejemplo 1: #A{4:#S{520}:1}" & @CRLF & _
"Ejemplo 2: #A{4:#S{520;F}:2}" & @CRLF & _
"Ejemplo 3: #A{4:#S{520}:5}" & @CRLF & _
"Ejemplo 4: '#A{4:#S{520;F}:8}'!=''" & @CRLF & _
"Ejemplo 5: '#A{4:#S{520}:7}'!=''" & @CRLF & _
"Ejemplo 6: '#A{4:#S{520;F}:4}'=='A'" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Ejemplos Inválidos:" & @CRLF & _
"" & @CRLF & _
"Ejemplo 1: #A{354:#S{500;F}:1:F}" & @CRLF & _
"Ejemplo 2: #A{354;#S{500;F};1}" & @CRLF & _
"Ejemplo 3: #S{500"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")