# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"#[NCRLTBUIOSFAGKP]\{(\d+):(#[NCRLTBUIOSFAGKP]\{\d+(?:;F)?\}|S|C|R)(:\d+)?\}"
test_str = ("Ejemplos Válidos:\n\n"
"Ejemplo 1: #A{4:#S{520}:1}\n"
"Ejemplo 2: #A{4:#S{520;F}:2}\n"
"Ejemplo 3: #A{4:#S{520}:5}\n"
"Ejemplo 4: '#A{4:#S{520;F}:8}'!=''\n"
"Ejemplo 5: '#A{4:#S{520}:7}'!=''\n"
"Ejemplo 6: '#A{4:#S{520;F}:4}'=='A'\n\n\n"
"Ejemplos Inválidos:\n\n"
"Ejemplo 1: #A{354:#S{500;F}:1:F}\n"
"Ejemplo 2: #A{354;#S{500;F};1}\n"
"Ejemplo 3: #S{500")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.