const regex = /<([^\s<>]*[dD]ate[^<>]*)>\d{13}<\/\1>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<([^\\s<>]*[dD]ate[^<>]*)>\\d{13}<\\\/\\1>', 'gm')
const str = `<dateCreated>1619155581543</dateCreated>
<dispatchDate>1619478000000</dispatchDate>
<deliveryDate>1619564400000</deliveryDate>
<thirteendigits>1619564400000</thirteendigits>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}