import re
regex = re.compile(r"<([^\s<>]*[dD]ate[^<>]*)>\d{13}<\/\1>", flags=re.MULTILINE)
test_str = ("<dateCreated>1619155581543</dateCreated>\n"
"<dispatchDate>1619478000000</dispatchDate>\n"
"<deliveryDate>1619564400000</deliveryDate>\n"
"<thirteendigits>1619564400000</thirteendigits>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")