$re = '/<([^\s<>]*[dD]ate[^<>]*)>\d{13}<\/\1>/m';
$str = '<dateCreated>1619155581543</dateCreated>
<dispatchDate>1619478000000</dispatchDate>
<deliveryDate>1619564400000</deliveryDate>
<thirteendigits>1619564400000</thirteendigits>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);