#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\d+\.?\d*$"
Local $sString = "A0.01" & @CRLF & _
"B0." & @CRLF & _
"C0" & @CRLF & _
"D"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)