const regex = new RegExp('\\d+\\.?\\d*$', 'gm')
const str = `A0.01
B0.
C0
D`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);