import re
regex = re.compile(r"\d+\.?\d*$", flags=re.MULTILINE)
test_str = ("A0.01\n"
"B0.\n"
"C0\n"
"D")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)