using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?=ab|bc|cd|de|ef|fg|gh|hi|ij|jk|kl|lm|mn|no|op|pq|qr|rs|st|tu|uv|vw|wx|xy|yz).){2,}.";
string input = @"abc - match abc
def - match def
lmnop - match lmnop
xxxxghixxxx - match ghi
ab - no match (not long enough)
zyx - no match (not in order)
q r s - no match (interceding chararacters)
tuwx - no match (missing v)
abcxxxdefghxxxabxyz
ababab
abcghixyz
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}