# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:(?=ab|bc|cd|de|ef|fg|gh|hi|ij|jk|kl|lm|mn|no|op|pq|qr|rs|st|tu|uv|vw|wx|xy|yz).){2,}."
test_str = ("abc - match abc\n"
"def - match def\n"
"lmnop - match lmnop\n"
"xxxxghixxxx - match ghi\n"
"ab - no match (not long enough)\n"
"zyx - no match (not in order)\n"
"q r s - no match (interceding chararacters)\n"
"tuwx - no match (missing v)\n"
"abcxxxdefghxxxabxyz\n"
"ababab\n"
"abcghixyz\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.