const regex = /(?:(?=ab|bc|cd|de|ef|fg|gh|hi|ij|jk|kl|lm|mn|no|op|pq|qr|rs|st|tu|uv|vw|wx|xy|yz).){2,}./gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?=ab|bc|cd|de|ef|fg|gh|hi|ij|jk|kl|lm|mn|no|op|pq|qr|rs|st|tu|uv|vw|wx|xy|yz).){2,}.', 'gm')
const str = `abc - match abc
def - match def
lmnop - match lmnop
xxxxghixxxx - match ghi
ab - no match (not long enough)
zyx - no match (not in order)
q r s - no match (interceding chararacters)
tuwx - no match (missing v)
abcxxxdefghxxxabxyz
ababab
abcghixyz
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}