const regex = /(?:\+?\d+)?[-.\s]?\d+[-.\s]?\d+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\+?\\d+)?[-.\\s]?\\d+[-.\\s]?\\d+', 'g')
const str = `(123) 123-123-123
(+91) 123-123-1234
1234567890
123 123 1234
+92 345 345 3456
+92 123-123-1234
-
// No match
8888888-dfd
12345678908888
3434 43434
123-123 1234
123 123-1234
+92 345 345 3456-
+92 345 345 3456--
+92 345 345 3456**
++92 123-123-1234
+92 123 123-1234
+++++++
3
-+
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}