import re
regex = re.compile(r"(?:\+?\d+)?[-.\s]?\d+[-.\s]?\d+")
test_str = ("(123) 123-123-123\n"
"(+91) 123-123-1234\n"
"1234567890\n"
"123 123 1234\n"
"+92 345 345 3456\n"
"+92 123-123-1234\n"
" - \n\n"
"// No match\n"
"8888888-dfd\n"
"12345678908888\n"
"3434 43434\n"
"123-123 1234\n"
"123 123-1234\n"
"+92 345 345 3456-\n"
"+92 345 345 3456--\n"
"+92 345 345 3456**\n"
"++92 123-123-1234\n"
"+92 123 123-1234\n"
"+++++++\n"
"3\n"
"-+ \n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")