$re = '/(?:\+?\d+)?[-.\s]?\d+[-.\s]?\d+/';
$str = '(123) 123-123-123
(+91) 123-123-1234
1234567890
123 123 1234
+92 345 345 3456
+92 123-123-1234
-
// No match
8888888-dfd
12345678908888
3434 43434
123-123 1234
123 123-1234
+92 345 345 3456-
+92 345 345 3456--
+92 345 345 3456**
++92 123-123-1234
+92 123 123-1234
+++++++
3
-+
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);