#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^\\\r\n]*\\([^\\\r\n]+(?:\\[^\\\r\n]+)+)\\[^\\\r\n]+$"
Local $sString = "c:\foo\bar\baz.txt" & @CRLF & _
"C:\FOO\BAR\BAZ.TXT" & @CRLF & _
"C:\FoO\BaR\BaZ.TxT" & @CRLF & _
"C:\FoO\BaR\test\BaZ.TxT" & @CRLF & _
"and so on." & @CRLF & _
"" & @CRLF & _
"Expression should match "foo\bar"." & @CRLF & _
"" & @CRLF & _
"C:\FOO\\\BAR\BAZ.TXT" & @CRLF & _
"C:\FOO\\BAZ.TXT"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")