re = /^[^\\\r\n]*\\([^\\\r\n]+(?:\\[^\\\r\n]+)+)\\[^\\\r\n]+$/m
str = 'c:\\foo\\bar\\baz.txt
C:\\FOO\\BAR\\BAZ.TXT
C:\\FoO\\BaR\\BaZ.TxT
C:\\FoO\\BaR\\test\\BaZ.TxT
and so on.
Expression should match "foo\\bar".
C:\\FOO\\\\\\BAR\\BAZ.TXT
C:\\FOO\\\\BAZ.TXT'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end