package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^\\\r\n]*\\([^\\\r\n]+(?:\\[^\\\r\n]+)+)\\[^\\\r\n]+$`)
var str = `c:\foo\bar\baz.txt
C:\FOO\BAR\BAZ.TXT
C:\FoO\BaR\BaZ.TxT
C:\FoO\BaR\test\BaZ.TxT
and so on.
Expression should match "foo\bar".
C:\FOO\\\BAR\BAZ.TXT
C:\FOO\\BAZ.TXT`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}