const regex = /((?!\n)[_\W]|^)(\w)(?<!\w'\w)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?!\\n)[_\\W]|^)(\\w)(?<!\\w\'\\w)', 'gm')
const str = `this_can't_be_an_example
this/is/an/example
this,is,an,example`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}