re = /((?!\n)[_\W]|^)(\w)(?<!\w'\w)/m
str = 'this_can\'t_be_an_example
this/is/an/example
this,is,an,example'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end