$re = '/((?!\n)[_\W]|^)(\w)(?<!\w\'\w)/m';
$str = 'this_can\'t_be_an_example
this/is/an/example
this,is,an,example';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);