package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)GC[AF]_\d+.\d`)
var str = `GCA_000739415.1 PRJNA245225 SAMN02732406 na 837 837 Porphyromonas gingivalis strain=HG66 latest Chromosome Major Full 2014/08/14 ASM73941v1 University of Louisville GCF_000739415.1 identical https://ftp.ncbi.nlm.nih.gov/genomes/all/GCA/000/739/415/GCA_000739415.1_ASM73941v1 an
GCZ_000739415.1
GCA_00073093487509384675083764508346759415.1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}