re = /GC[AF]_\d+.\d/m
str = 'GCA_000739415.1 PRJNA245225 SAMN02732406 na 837 837 Porphyromonas gingivalis strain=HG66 latest Chromosome Major Full 2014/08/14 ASM73941v1 University of Louisville GCF_000739415.1 identical https://ftp.ncbi.nlm.nih.gov/genomes/all/GCA/000/739/415/GCA_000739415.1_ASM73941v1 an
GCZ_000739415.1
GCA_00073093487509384675083764508346759415.1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end