using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<([^b][^>]*|b[^>]+)>.*?<\/\1>";
string input = @"<script>Hello world!</script>
<bold>Goodbye world!</bold>
<b>This turkey won't fly.</b>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}