$re = '/<([^b][^>]*|b[^>]+)>.*?<\/\1>/m';
$str = '<script>Hello world!</script>
<bold>Goodbye world!</bold>
<b>This turkey won\'t fly.</b>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);