re = /<([^b][^>]*|b[^>]+)>.*?<\/\1>/m
str = '<script>Hello world!</script>
<bold>Goodbye world!</bold>
<b>This turkey won\'t fly.</b>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end