$re = '/^[A-Z][a-z0-9_-]*( +[A-Z][a-z0-9_-]*)*$/m';
$str = 'TesT Name
TEST NAME
Test Name
Test-here Name-there
Test-here Name-------there';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);