package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)start:\s*(\d+)\s*end:`)
var str = `garbage 111222 garbage ... 999888 fewfew... start: 123456 end: start: 654321 end:`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}