// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)start:\s*(\d+)\s*end:").unwrap();
let string = "garbage 111222 garbage ... 999888 fewfew... start: 123456 end: start: 654321 end:";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}