$re = '/start:\s*(\d+)\s*end:/m';
$str = 'garbage 111222 garbage ... 999888 fewfew... start: 123456 end: start: 654321 end:';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);