using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^$\n(^$\n)*";
string substitution = @"";
string input = @"Nunc scelerisque risus lectus, id ultricies nulla vulputate eu.
Quisque fermentum pretium pharetra. Etiam nec felis diam.
Curabitur pretium suscipit ex sed pulvinar.
In interdum eget massa sed posuere.
Aliquam rutrum auctor tempor.
Praesent sodales eu massa rhoncus efficitur.
Proin egestas non erat vitae feugiat. Suspendisse rutrum placerat fermentum.
Nulla tincidunt leo ut lectus semper pellentesque.
Lorem ipsum dolor sit amet, consectetur adipiscing elit.
Ut scelerisque velit ac porta tristique.
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}